Sign Up for Training |
Jet Express Support |
Jet Reports Company Site
Jet 365 Financials
Jet Professional
Jet Enterprise
Downloads
Community
Submit a Request
Give Feedback

System Requirements for Jet Professional Excel Add-in


Jet Professional 2018

(current version)

 

Database Connectivity

Jet Professional can connect to any of the following data sources:

  • Microsoft Dynamics NAV version 5.0 through 2017, or
  • Microsoft Dynamics NAV version 4.0 SP1 through 2009R2 (if using Windows Vista SP2), or
  • Microsoft Dynamics NAV 2013 through 2017 (if using the Jet Web Portal)
  • Microsoft Dynamics GP version 9 or later, or
  • Microsoft CRM (on premises), or
  • Microsoft SQL Server 2005 or later (must be supported by the version of Windows), or
  • An OLE or ODBC compliant database

(For Dynamics NAV users, the versions listed above are referring to the executables.  Any version of the business objects may be used.)

With Jet Enterprise licensing, the following data sources are also available:

  • Jet Data Warehouse
  • Jet Enterprise OLAP Cubes

 

Jet Excel add-in

Jet Professional includes an Excel add-in which is used by designers to create reports and can be used to refresh and schedule reports.


The system requirements for the Excel add-in are:

 

Operating System
  • Microsoft Windows Server 2016 - 2008 SP2 
  • Microsoft Windows 10 - Microsoft Windows Vista SP2

Microsoft Office

  • Microsoft Office 2016 - 2007
  • Microsoft Office 365 2016-2013 (Desktop Edition Only)

For our customers using Microsoft Dynamics NAV 2009 R2 or earlier, Jet Reports recommends the 32-bit editions of MS Office.  "Click-to-Run" installations are not recommended.  Jet Reports cannot support installations where multiple copies of MS Office are installed. 

Prerequisites
  • NAV Web Services (if using NAV 2013 or higher and have no access to the SQL Server)
  • Microsoft .Net Framework 4.5 (including 'ADOMD.NET for SQL Server 2005')

Hardware

(minimum)

  • Processor: 1.4GH
  • RAM: 2GB
  • Disk space: 2GB

 

 

Jet Web Portal and Jet Service Tier

Jet Professional also provides a Jet Web Portal and Jet Service Tier which can be hosted on-premises. This allows users to view, manage and refresh their reports from within an Internet browser.

User requirements for the Jet Web Portal are:

Internet
Browser

  IE 10+, Chrome, Firefox, Safari, Edge

(unless otherwise specified, support is maintained for the most recent release)

Please note: In order to use the Jet Web Portal, cookies must be enabled in your browser.

Prerequisites
(for viewing reports online)
  • OneDrive or OneDrive for Business
    (Most free OneDrive accounts are supported - please test)


Server requirements for the Jet Web Portal are

Operating System

Recommended:
  • Microsoft Windows  Server 2012 R2 - 2008 SP2
Supported:
  • Microsoft Windows 10 - Microsoft Windows Vista SP2
Prerequisites
  • Microsoft .Net Framework 4.5 (including ADOMD.NET for SQL Server 2005)
  • TLS Certificate
  • Active Directory

Hardware
(minimum)

  • Processor: 1.4GH
  • RAM: 2GB
  • Disk space: 2GB

Microsoft IIS

  • Version 7.0 or higher 

See Also

Requirements for using the Jet Service Tier

 

Security Requirements

Organizations wishing to provide data to remote devices outside of their network should purchase a domain-validated SSL Certificate from an outside vendor in order to do so.

It is possible to use the Jet Web Portal with a self-signed certificate. However, Jet Reports recommends the use of a domain-validated SSL Certification. This may involve an additional charge. Some recommended providers to look at are Namecheap, RapidSSL and DigiCert. Approximate costs range from $10 to $175 per year.

Domain Validation certificates for TLS encryption is also available at no cost from Let's Encrypt (cross-signed by IdenTrust). At the time of its initial availability, such certificates did not support Windows IIS.  If such a certificate now supports Windows IIS, it could be used with the Jet Web Portal.

 

Language Support

Czech, Danish, Dutch, English, Finnish, French, German, Greek, Hungarian, Icelandic, Italian, Japanese, Norwegian, Polish, Portuguese, Russian, Spanish, Swedish

 



 

Jet Professional 2017 (including R2 and R3) - Supported Version

Database Connectivity

Jet Professional can connect to any of the following data sources:

  • Microsoft Dynamics NAV version 5.0 through 2017, or
  • Microsoft Dynamics NAV version 4.0 SP1 through 2009R2 (if using Windows Vista SP2), or
  • Microsoft Dynamics GP version 9 or later, or
  • Microsoft CRM (on premises), or
  • Microsoft SQL Server 2005 or later (must be supported by the version of Windows), or
  • An OLE or ODBC compliant database
    (note: NAV 2017 compatibility requires version 16.0.16252.0 or higher)

For Dynamics NAV users, the versions listed above are referring to the executables .  Any version of the business objects may be used. 

With Jet Enterprise licensing, the following data sources are also available:

  • Jet Data Warehouse
  • Jet Enterprise OLAP Cubes

 

Jet Excel add-in

Jet Professional includes an Excel add-in which is used by designers to create reports and can be used to refresh and schedule reports.

The system requirements for the Excel add-in are:

Operating System
  • Microsoft Windows Vista SP2 - Microsoft Windows 10
  • Microsoft Windows Server 2008 SP2 - 2016
Microsoft Office
  • Microsoft Office 2007 - 2016

For our customers using Microsoft Dynamics NAV 2009 R2 or earlier, Jet Reports recommends the 32-bit editions of MS Office.  "Click-to-Run" installations are not recommended.  Jet Reports cannot support installations where multiple copies of MS Office are installed. 

Prerequisites
  • NAV Web Services (if using NAV 2013 or higher and have no access to the SQL Server)
  • Microsoft .Net Framework 4.5 (including 'ADOMD.NET for SQL Server 2005')

Hardware

(minimum)

  • Processor: 1.4GH
  • RAM: 2GB
  • Disk space: 2GB

 

 

Jet Web Portal and Jet Service Tier

Jet Professional also provides a Jet Web Portal and Jet Service Tier which can be hosted on-premises. This allows users to view, manage and refresh their reports from within an Internet browser.

User requirements for the Jet Web Portal are:

Internet
Browser
  • IE 10+
  • Chrome
  • Firefox
  • Safari
  • Edge

(unless otherwise specified, support is maintained for the most recent release)

Please note: In order to use the Jet Web Portal, cookies must be enabled in your browser.

Prerequisites
  • OneDrive or OneDrive for Business


Server requirements for the Jet Web Portal are

NAV Connectivity
  • Dynamics NAV 2013 - NAV 2017
Operating System
Recommended:
  • Microsoft Windows  Server 2008 SP2 - 2012 R2
Supported:
  • Microsoft Windows Vista SP2 - Windows 10
Prerequisites
  • Microsoft .Net Framework 4.5 (including 'ADOMD.NET for SQL Server 2005')
  • TLS Certificate
  • Active Directory

Hardware
(minimum)

  • Processor: 1.4GH
  • RAM: 2GB
  • Disk space: 2GB

Microsoft IIS

  • Version 7.0 or higher 

See Also

Requirements for using the Jet Service Tier

 

Security Requirements

Organizations wishing to provide data to remote devices outside of their network should purchase a domain-validated SSL Certificate from an outside vendor in order to do so.

It is possible to use the Jet Web Portal with a self-signed certificate. However, Jet Reports recommends the use of a domain-validated SSL Certification. This may involve an additional charge. Some recommended providers to look at are Namecheap, RapidSSL and DigiCert. Approximate costs range from $10 to $175 per year.

Domain Validation certificates for TLS encryption is also available at no cost from Let's Encrypt (cross-signed by IdenTrust). At the time of its initial availability, such certificates did not support Windows IIS.  If such a certificate now supports Windows IIS, it could be used with the Jet Web Portal.

 



Language Support

Czech, Danish, Dutch, English, Finnish, French, German, Greek, Hungarian, Icelandic, Italian, Japanese, Norwegian, Polish, Portuguese, Russian, Spanish, Swedish



 


Jet Essentials 2015 Update 1

(Supported Version)


Component

Requirement

Operating System**

· Microsoft Windows 10

· Microsoft Windows Server 2008 - 2012 R2

· Microsoft Windows 8 and 8.1

· Microsoft Windows 7

· Microsoft Windows Vista

 

Microsoft Office****

 

(32 or 64-bit) ^

· Microsoft Office 2010 - 2016**

· Microsoft Office 365 (2013-2016 Desktop Edition only)**

· Microsoft Office 2007

 

Database***

· Microsoft Dynamics NAV Version 4.0 SP1 through 2016 (NAV v5.0 - 2016 if using Windows 7 or higher) *, or

 

· Microsoft Dynamics GP Version 9 or later, or


· Microsoft Dynamics CRM (on premises), or

 

· Microsoft SQL Server 2005 or later^^, or

 

· An OLE or ODBC compliant database

 

 

 

Prerequisites

· NAV Web Services (if using NAV 2013 or higher and have no access to SQL Server)

 

· Microsoft .NET Framework 4.5

(incl. ADOMD.NET for SQL Server 2005)



See Also

Requirements for using the Jet Service Tier

 


Jet Essentials 2015

(Supported Version)


Component

Requirement

Operating System**

· Microsoft Windows Vista

 

· Microsoft Windows 7

· Microsoft Windows 8 and 8.1

· Microsoft Windows Server 2008 - 2012 R2

 

Microsoft Office****

· Microsoft Office 2007

 

· Microsoft Office 2010 - 2013 (32 or 64-bit)^

· Microsoft Office 365
(32-bit or 64-bit 2013 Desktop Edition only)^

 

Database***

· Microsoft Dynamics NAV Version 4.0 SP1 through 2015 (NAV v5.0 - 2015 if using Windows 7 or higher) *, or

 

· Microsoft Dynamics GP Version 9 or later, or


· Microsoft Dynamics CRM (on premises), or

 

· Microsoft SQL Server 2005 or later^^, or

 

· An OLE or ODBC compliant database

 

 

 

Prerequisites

· NAV Web Services (if using NAV 2013 or higher and have no access to SQL Server)

 

· Microsoft .NET Framework 4.0

(incl. ADOMD.NET for SQL Server 2005)


 


Jet Essentials 2013 Update 1

(Supported Version)


Component

Requirement

Operating System**

· Microsoft Windows XP

· Microsoft Windows Server 2003

 

· Microsoft Windows Vista

· Microsoft Windows 7

· Microsoft Windows 8 and 8.1

· Microsoft Windows Server 2008 & 2008 R2

· Microsoft Windows Server 2012

 

Microsoft Office****

· Microsoft Office 2003

· Microsoft Office 2007

 

· Microsoft Office 2010 (32 or 64-bit)^!

· Microsoft Office 2013 (32 or 64-bit)^!

· Microsoft Office 365 (Desktop Edition only)^!

 

Database***

· Microsoft Dynamics NAV Version 4.0 SP1 - NAV 2013
(NAV v5.0 - 2013 if using Windows 7 or higher) *, or

 

· Microsoft Dynamics GP Version 9 or later, or


· Microsoft Dynamics CRM (on premises), or

 

· Microsoft SQL Server 2000 or later^^, or

 

· An OLE or ODBC compliant database

 

 

 

Prerequisites

· NAV Web Services (if using NAV 2013 and have no access to SQL Server)

 

· Microsoft .NET Framework 4.0

(incl. ADOMD.NET for SQL Server 2005)

 


Jet Essentials 2013

(Supported Version)


Component

Requirement

Operating System**

· Microsoft Windows XP

· Microsoft Windows Server 2003

 

· Microsoft Windows Vista

· Microsoft Windows 7

· Microsoft Windows 8 and 8.1

· Microsoft Windows Server 2008 & 2008 R2

· Microsoft Windows Server 2012

 

Microsoft Office****

· Microsoft Office 2003

· Microsoft Office 2007

 

· Microsoft Office 2010 (32 or 64-bit)^!

· Microsoft Office 2013 (32 or 64-bit)^!

· Microsoft Office 365 (Desktop Edition only)!

 

Database***

· Microsoft Dynamics NAV Version 4.0 SP1 - 2013 (NAV v5.0 - 2013 if using Windows 7 or higher) *, or

 

· Microsoft Dynamics GP Version 9 or later, or


· Microsoft Dynamics CRM (on premises), or

 

· Microsoft SQL Server 2000 or later^^, or

 

· An OLE or ODBC compliant database

 

 

 

Prerequisites

· NAV Web Services (if using NAV 2013)

· Microsoft .NET Framework 4.0

(incl. ADOMD.NET for SQL Server 2005)

 

 

 


Jet Essentials 2012R2

(No Longer Supported)


Component

Requirement

Operating System**

· Microsoft Windows XP

· Microsoft Windows Server 2003

 

· Microsoft Windows Vista

· Microsoft Windows 7

· Microsoft Windows Server 2008

· Microsoft Windows Server 2008 R2

 

Microsoft Office****

· Microsoft Office 2003

· Microsoft Office 2007

 

· Microsoft Office 2010 (32 or 64-bit)^!

· Microsoft Office 2013 (32 or 64-bit)^!

 

Database***

· Microsoft Dynamics NAV Version 4.0 SP1 through NAV 2009R2
(NAV v5.0-2009R2 if using Windows 7 or higher) *, or

· Microsoft Dynamics GP Version 9 thru 2010R2, or

· Microsoft Dynamics CRM (on premises), or

· Microsoft SQL Server 2000 or later, or

· An OLE or ODBC compliant database

 

 

 

Prerequisites

· Microsoft .NET Framework 4.0

(incl. ADOMD.NET for SQL Server 2005)

 

 

 


Jet Essentials 2012

(No Longer Supported)

 

Component

Requirement

Operating System**

· Microsoft Windows XP

· Microsoft Windows Server 2003

 

· Microsoft Windows Vista

· Microsoft Windows 7

· Microsoft Windows Server 2008

 

Microsoft Office****

· Microsoft Office 2003

· Microsoft Office 2007

 

· Microsoft Office 2010 (32 or 64-bit)^!

 

Database***

· Microsoft Dynamics NAV Version 4.0 SP1 through NAV 2009R2
(NAV v5.0 - 20092 if using Windows 7 or higher) *, or

· Microsoft Dynamics GP Version 9 thru 2010R2, or

· Microsoft SQL Server 2000 or later, or

· An OLE or ODBC compliant database

 

 

 

Prerequisites

· Microsoft .NET Framework 4.0

(incl. ADOMD.NET for SQL Server 2005)

 

 




 


Jet Essentials 2010R2 and 2011``

(No Longer Supported)

 

Component

Requirement

Operating System**

· Microsoft Windows XP

· Microsoft Windows Server 2003

 

· Microsoft Windows Vista

· Microsoft Windows 7

· Microsoft Windows Server 2008

 

Microsoft Office****

· Microsoft Office 2003

· Microsoft Office 2007

 

· Microsoft Office 2010 (32 or 64-bit)^!

 

Database***

· Microsoft Dynamics NAV Version 4.0 SP1 through NAV 2009R2
(NAV v5.0 - 20092 if using Windows 7 or higher) *, or

· Microsoft Dynamics GP Version 9 thru 2010R2, or

· Microsoft SQL Server 2000 or later, or

· An OLE or ODBC compliant database

 

 

 

Prerequisites

· Microsoft .NET Framework 4.0

(incl. ADOMD.NET for SQL Server 2005)

 

 

 


Jet Essentials 2010``

( No Longer Supported )

 

Component

Requirement

Operating System**

· Microsoft Windows XP

· Microsoft Windows Server 2003

 

· Microsoft Windows Vista

· Microsoft Windows 7

· Microsoft Windows Server 2008

 

Microsoft Office****

· Microsoft Office 2003

· Microsoft Office 2007

 

· Microsoft Office 2010 (32 or 64-bit)^!

 

Database***

· Microsoft Dynamics NAV Version 4.0 SP1 through NAV 2009R2
(NAV v5.0 - 2009R2 if using Windows 7 or higher) *, or

· Microsoft Dynamics GP Version 9 thru 2010R2, or

· Microsoft SQL Server 2000 or later, or

· An OLE or ODBC compliant database

 

 

 

Prerequisites

· Microsoft .NET Framework 4.0

 

 


Jet Reports 2009``

> ( No Longer Supported )


Component

Requirement

Operating System**

· Microsoft Windows 2000

· Microsoft Windows Server 2000

· Microsoft Windows XP

· Microsoft Windows Server 2003

· Microsoft Windows Vista

· Microsoft Windows 7

· Microsoft Windows Server 2008

 

Microsoft Office****

· Microsoft Office 2002/XP

· Microsoft Office 2003

· Microsoft Office 2007

· Microsoft Office 2010 (32-bit Edition) !
{Jet version 9.2.10131 or higher}

 

Database***

· Microsoft Dynamics NAV Version 4.0 SP1 to Version 2009-6.0.29626 (NAV Version 5.0 or 6.0.29626 if using Windows 7 or higher) *, or

 

· Microsoft Dynamics GP Version 8 or later, or

· Microsoft SQL Server 2000 or later, or

· An OLE or ODBC compliant database

 

 

Prerequisites

· Microsoft .NET Framework 2.0

 


 


Jet Reports V7``

( No Longer Supported )


Component

Requirement

Operating System

· Microsoft Windows 2000

· Microsoft Windows Server 2000

· Microsoft Windows XP

· Microsoft Windows Server 2003

· Microsoft Windows Vista

 

Microsoft Office

· Microsoft Office 2000

· Microsoft Office 2002/XP

· Microsoft Office 2003

· Microsoft Office 2007

 

Database

· Microsoft Dynamics NAV Version 3.01 to 5.0*,

· Microsoft Dynamics GP Version 8 or later, or

· Microsoft SQL Server 2000 or later, or

· An OLE or ODBC compliant database

 

Prerequisites

· Microsoft .NET Framework 2.0

 

 

 Notes

^ For our customers using Excel 2010 or higher with Microsoft Dynamics NAV 2009 R2 or earlier, Jet Reports recommends the 32-bit editions of MS Office.
^^ The version of SQL Server must be supported by the operating system being used.
! "Click-to-Run" installs are NOT recommended
* For Microsoft Dynamics NAV users, the versions listed above are referring to the executables .  Any version of the business objects may be used. 
** Includes both 32-bit and 64-bit versions, if applicable.
*** Microsoft Dynamics NAV 4.0 (including SP1/SP2/SP3) is not supported on Windows 7 or higher, or Server 2008 or higher.
**** Jet Reports recommends that only one installation of MS Office be present.  Jet Reports cannot support installations where multiple copies of MS Office are installed.
``

Mainstream support for Jet Reports 2007/v7 ended as of 10/10/2012.  Mainstream support for Jet Reports 2009 ended on 9/17/2014.  Mainstream support for Jet Reports 2010 ended on 9/30/2015.  Mainstream support for Jet Essentials 2010R2 ended on 3/13/2016.  Mainstream support for Jet Essentials 2011 ended on 8/30/2016.

Requirements information is provided for our clients maintaining compatibility with older versions of related components.


Minimum System Requirements for Jet Reports:

Processor

1 GHz processor or higher

Memory

512 MB RAM or higher

Hard disk

100 MB free space*

Display

1024x768 or higher resolution monitor



*Not including space requirements for Microsoft .NET Framework


Language Support

Czech, Danish, Dutch, English, Finnish, French, German, Greek, Hungarian, Icelandic, Italian, Japanese, Norwegian, Polish, Portuguese, Russian, Spanish, Swedish

 
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments