Sign Up for Training |
Jet Global Company Site
Community
Downloads
Submit a Request
Give Feedback

Pre-Installation Checklist for Jet Analytics


Moderate - requires SQL experience and Admin permissions

Overview

To ensure a fast and successful deployment of Jet Analytics (Jet Data Manager), please complete the following checklist prior to installation.

Process

  1. Confirm the operating system on the server meets minimum requirements

    • The operating system on the server must be a currently supported Microsoft OS (i.e. Windows Server 2008 or later and ensuring the latest service pack and OS patches are installed)
    • The latest available service packs should also be installed for the operating system
    • Refer to the Server Sizing Recommendations article for questions regarding hardware requirements.
  2. Confirm the server has internet access

    This will be required to activate the Jet Data Manager.

    Inbound TCP ports 2383 and 1433 (default values for SQL Server Analysis Services and SQL Server Database Engine) should be open to the internal network.

  3. Confirm SQL Server components are installed with the latest service packs

    Jet Analytics requires Microsoft SQL Server 2008 through SQL Server 2017 (Standard, Enterprise, or Business Intelligence edition) to be installed with the latest service packs. The following components must be installed prior to the installation:

    • SQL Server (Database Engine)
    • SQL Server Integration Services (SSIS)
    • SQL Server Analysis Services Multidimensional (SSAS)

    Pre-release versions of SQL Server are not guaranteed to be compatible with Jet Analytics. We aim to be compatible with such versions within a month of the version's release date.

    In order to determine which version of SQL you are currently using please refer to the following article: How To Determine Your Version Of SQL Server

    In order to determine which SQL Server Components are installed, please refer to the following article:  Ensuring SQL Server Components are Installed

  4. Ensure proper access to SQL components

    During the installation, we will need permissions to each SQL Server component

    In order to determine the minimum permissions that are required see: Jet Data Manager Minimum SQL Server Permissions
  5. Confirm that the latest version of Microsoft .NET Framework (Version 4.6.2 or later) is installed

  6. Create an Active Directory user account (Utility User) that is part of the domain

    The utility user serves to run the scheduled updates and will be used as the log on user for the scheduler service.

  7. Confirm that the client machines are joined to the domain

    In order for end users to connect to the OLAP cubes, they must be on a computer which is joined to the domain.

  8. Ensure necessary drivers are installed for connecting to the data source(s)

    Some data sources will require an ODBC driver to facilitate a connection.

    If you are using a NAV Native database, Jet will require the use of an ODBC connection. You will need to have a Nav Native ODBC Driver installed. The ODBC driver needs to match your NAV version. You can find the ODBC driver in the NAV installation media under the NODBC folder. You must have the NAV Adapter objects imported and processed in your NAV database before configuring the ODBC connection.

    Note: Jet only supports NAV Native database versions 4.0 and newer, this is different from your executables version. Please verify your NAV Native database is supported.

    Other data sources, such as SQL Server data sources may not require an ODBC connection. 

    Most ODBC drivers can be found on the installation media, or online by visiting the software vendor's website.

    If Excel data sources will be used the ACE OLEDB provider will need to be installed. If Excel is installed on the server this should already be in place, otherwise, a standalone installation package will need to be downloaded from the Microsoft site.

  9. If using Dynamics NAV, ensure that the "Jet Reports Statistics" granule has been added to your NAV license (only for NAV 2009 and prior)

    There are a set of NAV objects that are added to the NAV database when using NAV 2009 and older. In order to properly import and run these objects during the installation process, you will need to have a granule added to your NAV license that permits you to do so.

    You can refer to details about getting the granule added to your NAV license in the KB article here: NAV Adapter Licensing
  10. If using Dynamics NAV, ensure access to NAV resources.

    During the installation, we will need to import our adapter objects into the NAV database. This is referred to as the NAV Adapter. In order to import these objects we will need to access the following environments with "Super" permissions:

    • NAV Development Environment (NAV 2013 or later)
    • NAV Classic Client (NAV 2009 or older)

    For an overview of the adapter import process please refer to:

  11. If using Dynamics AX, ensure access to AX resources.

    During the installation, you will need to import our adapter objects into the AX database. This is referred to as the AX Adapter. In order to import these objects you will need to access the following environments with "admin" permissions:

    For an overview of the adapter import process please refer to:

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments